const regex = /ab(?=(.*?)(bc)(.*))(?!.*(?:a|cb|cd).*\3)\1\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ab(?=(.*?)(bc)(.*))(?!.*(?:a|cb|cd).*\\3)\\1\\2', 'gm')
const str = `0abbc1ab2bc3ababc4abcbbc5ab6bc7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}