using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bFC\b(?:(?!\bFC\b).)*?1";
string input = @": FC Relacionado con Paciente FC Protocolo1 FC Comunicacion entre Profesionales1 FC Disponibilidad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}