package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)`)
var str = `a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}