const regex = /^(.*)\1+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)\\1+', 'gm')
const str = `The quick brown fox jumps over the lazy dogThe quick brown fox jumps over the lazy dog
ApplesApplesApples
IBM AT Computer
Lamp ShadeLamp Shade
OrangesOranges
I am a Potato
i am i am i am a potato`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);