re = /\/(?P<params>[^\/#].*(?:[^\n.].{2}$|.[^\nj].$|.{2}[^\ns]$))$/m
str = '/#something
/something
/something.js
/something.ja
/somethingjs
/somethingjs.
/somethin.gjs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end