re = /^\d{3}(?:-\d{3})?(?:\s*(?:,|and|or)\s*\d{3}(?:-\d{3})?)*(?=,|$)/m
str = '345
346-348
234,235,236,237-239
234, 235, 236, 237-239
234,234, 236 and 237-239
234,234, 236 or 237-239
3454
454,4567 (match only 454)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end