$re = '/(?<=\S)-(?=\S)/m';
$str = 'Adapter - BNC Male to BNC-Female, Right Angle
Adapter -BNC Male to BNC-Female, Right Angle
Adapter- BNC Male to BNC-Female, Right Angle
-test
test-
- test
test -
test-test';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;