$re = '/^.*odh.*develop|feature.*/m';
$str = 'AXAes-engineering-office/ODH_new/build_ODH/axaes-odh-catalog/develop
ODH/odh_jobs/axaes-odh-client/feature/test-regex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);