import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Rule\\((?P<flow_number>[^,]+),\\s(?P<protocol>[^,]+),\\s(?P<from_ip>\\[[^\\]]+\\]),\\s(?P<to_ip>\\[[^\\]]+\\]),\\s(?P<port>[^,)]+)\\)";
final String string = "Rule(F1, HTTPS TCP, ['ip', 'ip'], ['www.google.ca', '8.8.8.8'], 443)\n\n"
+ "Rule(F2, HTTPS TCP, ['ip', 'ip'], ['ip'], 443)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}