// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":[a-zA-Z0-9_]*").unwrap();
let string = "SELECT cID, cTIME, cDATA FROM tMyTable WHERE cTIME = '0000-00-00 00:00:00' and cID > :param1;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}