import Foundation
let pattern = #"^(([A-Z][a-z]+)(?=[\ ])|([A-Z][a-z]*[\'\-])(?=[A-Z]?[a-z]+)|([A-Z][a-z]+)(?![\ '\-])|(?<=[\'\-])([a-z]+)|(?<=[a-z])([\ ])(?=[A-Z]))+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Kamal Manil
Kamal O'Neil
Kamal Manil Malaka
Kamal Al-Shaba
Al-shaba
O'neil
Ol'Neil
Jo Jo
Jo
Kamal Manil
Kamal O' Neil
Kamal Manil Malaka
Kamal Al- Shaba
Al -shaba
O 'neil
Jo Jo
A B C Jo
Kamal SDF -''''sdf''-
A
a
A B
-Shana
'Neil
-shaba
'neil
([A-Z][a-z]+(?![\'\-]))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)