use strict;
my $str = 'https://www.google.com/today/SUNDAY/abcde2.hopeho.3345GETD?weatherType=RAOM&...
https://www.google.com/today/Monday/jbkwe3.ho4eho.8495GETD?weatherType=WHTDSG&...';
my $regex = qr/(?i)(?:sun|mon|tues|wednes|thurs|fri|satur)day\/\K[^?]+(?=\?weatherType)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}