using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))";
string input = @"12
1
1234
00121300";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}