#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_{3}(?=.*[a-zA-Z_])(.*[a-zA-Z_])_{3}"
Local $sString = "___string_string___ " & @CRLF & _
"___test___" & @CRLF & _
"__something__" & @CRLF & _
"___sda1231___" & @CRLF & _
"______"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")