#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=2020)\d{2}"
Local $sString = "Diagnostics 20200826-12345moretext.zip" & @CRLF & _
"" & @CRLF & _
"Diagnostics 20205839-12345moretext.zip" & @CRLF & _
"" & @CRLF & _
"Diagnostics 20209999-12345moretext.zip" & @CRLF & _
"" & @CRLF & _
"//doesnt start with 2020" & @CRLF & _
"Diagnostics 20001212-12345moretext.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")