const regex = /(?<=2020)\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=2020)\\d{2}', 'gm')
const str = `Diagnostics 20200826-12345moretext.zip
Diagnostics 20205839-12345moretext.zip
Diagnostics 20209999-12345moretext.zip
//doesnt start with 2020
Diagnostics 20001212-12345moretext.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}