package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<City>.*)\s(?<State>[^\s\d]+)\s?(?<Zip>[0-9\-]{5,})?$`)
var str = `Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345
TYSON CORNER VA
Falls Church VA
Arlington Virginia
Arlington VIRGINIA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}