import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<City>.*)\\s(?<State>[^\\s\\d]+)\\s?(?<Zip>[0-9\\-]{5,})?$";
final String string = "Falls Church VA 23112\n"
+ "Arlington Virginia 24221-2345\n"
+ "Arlington VIRGINIA 24221-2345\n"
+ "TYSON CORNER VA 232342345\n"
+ "TYSON CORNER VA\n\n"
+ "Falls Church VA\n"
+ "Arlington Virginia\n"
+ "Arlington VIRGINIA\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}