#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "config\/info\/(newplan|oldplan|specplan)\/"
Local $sString = "/config/info/specplan/" & @CRLF & _
"/config/info/specplan1/" & @CRLF & _
"/config/info/oldplan/" & @CRLF & _
"/config/info/newplan/" & @CRLF & _
"/config/info/new1plan/" & @CRLF & _
"/config/info/newoldplan/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")