$re = '/^(?=.*[A-Z]|())(?=.*[a-z]|())(?=[^0-9\r\n]+$|())(?=[^\\\\!-\/:-@\[\]-`{-~\r\n]+$|())(?=.{2,40}$|()).+/m';
$str = '9876LKIU
P,a
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);