import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?<FirstOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\\.(?<SecondOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\\.(?<ThirdOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\\.(?<FourthOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))){1}\\b";
final String string = "Should Match:\n"
+ "204.131.100.104\n"
+ "255.255.005.055\n"
+ "192.168.10.1\n"
+ "172.16.1.1\n"
+ "10.10.10.1\n"
+ "1.2.3.4\n"
+ "255.255.255.255\n"
+ "001.02.3.004\n"
+ "123.145.254.189:8080\n"
+ "1.2.3.4-4.3.20.1\n"
+ "4.3.2.1.9.8.7.6\n"
+ "Shouldnt match:\n"
+ "255.256.255.255\n"
+ "172.999.2.3\n"
+ "this is a string1.2.3.4\n"
+ "this is another 1.2.3.4string\n"
+ "144.109.279.255\n"
+ "v1.2.3.4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}