$re = '/^([^.]*\.){2}\K/m';
$str = '1.01.2
1.01.3
1.02.1';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;