$re = '/Donors_(.+?)_Ti/';
$str = 'Donors_1233klf323sd_Ti';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);