#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^https?:\/\/[\w.-]+(?<!\.domain\.edu)$"
Local $sString = "https://www.google.com" & @CRLF & _
"http://not.the.best.example.org" & @CRLF & _
"http://another.bad.example.erewhon.edu" & @CRLF & _
"https://my.domain.com" & @CRLF & _
"https://your.page.domain.edu" & @CRLF & _
"http://good.domain.edu"
Local $sSubst = "https://my.domain.edu"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)