$re = '/^https?:\/\/[\w.-]+(?<!\.domain\.edu)$/m';
$str = 'https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu';
$subst = "https://my.domain.edu";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;