re = /^(https?:\/\/)[\w.-]+(?<!\.domain\.edu)$/m
str = 'https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu'
subst = '\\1my.domain.edu'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result