$re = '/(b[^]*)/';
$str = 'map apple dog apple banana apple banana apple';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);