#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^[ ]{0,}$)^\S{1,}$"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
"abcd" & @CRLF & _
"ABCD1234" & @CRLF & _
"#$%^&*()_+={}" & @CRLF & _
"abc def" & @CRLF & _
"ABC 123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")