using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ng-click=""vm\.onClickTab\((.*?)'\)";
string substitution = @"ng-click=""vm\.onClickTab\($1', $event\)";
string input = @" ng-click=""vm.onClickTab('wanted')""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}