import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ng-click=\"vm\\.onClickTab\\((.*?)'\\)";
final String string = " ng-click=\"vm.onClickTab('wanted')\"";
final String subst = "ng-click=\"vm\\.onClickTab\\($1', $event\\)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}