use strict;
my $str = ' ng-click="vm.onClickTab(\'wanted\')"';
my $regex = qr/ng-click="vm\.onClickTab\((.*?)'\)/p;
my $subst = 'ng-click="vm\\.onClickTab\\($1\', $event\\)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";