const regex = /^(?![\d.]{18})\d{1,3}(?:\.\d{3})*(?:,\d\d?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\d.]{18})\\d{1,3}(?:\\.\\d{3})*(?:,\\d\\d?)?$', 'gm')
const str = `1.000.000.000.000
1.000.000.000.000,00
1
1,00
123,45
10.000.000.000.000
10.000.000.000.000,00
10.000.000.000.000.000
10.000.000.000.000.000,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}