import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-z]+(?:(?!\\n)[^a-z])+){3}((?=(?:(?![aeiou])[a-z])*[aeiou](?:(?![aeiou])[a-z])*[^a-z](*SKIP)(?!)|)[a-z]+)";
final String string = "Here is my Text which \n"
+ "I now have *starred* the words which i would like accounted for\"\n"
+ "I would like the end result to be Lines 3 Words 6.\n"
+ "Python Regular expression **rules** have me trying things that \n"
+ "I have listed below. All of them are usable but I would like \n"
+ "To understand how to customize it for **production** to use.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}