import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)Store number – ([\\d\\D]*)\\n.*StreetA – ([\\d\\D]*)\\n.*City – ([\\d\\D]*)\\n.*State_id – ([\\d\\D]*)\\n.*Postal Code – ([\\d\\D]*)\\n.*Store Name – ([\\d\\D]*)\\n.*Phone Number – ([\\d\\D]*)\\n.*Tax Rates.*\\n.*Tax table 1 – ([\\d\\D]*)\\n.*Tax table 2 – ([\\d\\D]*)\\n.*Tax table 3 – ([\\d\\D]*)\\n.*Tax table 4 – ([\\d\\D]*)\\n.*Tax table 5 – ([\\d\\D]*)\\n.*Artistree vendor – ([\\d\\D]*)\\n.*Store Group – ([\\d\\D]*)\\n.*Store Zone number – ([\\d\\D]*)";
final String string = "FP Team,\n\n"
+ "Please install the Live database for store 1384. The updates have been completed.\n\n"
+ "• Store number – 1384\n"
+ "• StreetA – 1275 York Rd, Ste 21A\n"
+ "• City – Gettysburg\n"
+ "• State_id – PA\n"
+ "• Postal Code – 17325-7565\n"
+ "• Store Name – Gettysburg, PA\n"
+ "• Phone Number – (717) 420-8200\n"
+ "• Tax Rates\n"
+ " o Tax table 1 – 6.0000%\n"
+ " o Tax table 2 – 0.0000%\n"
+ " o Tax table 3 – 0.0000%\n"
+ " o Tax table 4 – 0.0000%\n"
+ " o Tax table 5 – N/A\n"
+ "• Artistree vendor – Kernersville\n"
+ "• Store Group – US.201308\n"
+ "• Store Zone number – 2030";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}