package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s`)
var str = `
Password archivio: 6646
Per conto di: pec@pec.anekitalia.com
posta-certificata@telecompost.it`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}