const regex = /\bPassword\sarchivio:\s\d+\n\n\nPer\sconto\sdi:\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bPassword\\sarchivio:\\s\\d+\\n\\n\\nPer\\sconto\\sdi:\\s', 'gm')
const str = `
Password archivio: 6646
Per conto di: pec@pec.anekitalia.com
posta-certificata@telecompost.it`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}