package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z]+) (inc|dec) (-?\d+) if ([a-z]+) (.+) (-?\d+)`)
var str = `b inc 5 if a > 1
a inc 1 if b < 5
c dec -10 if a >= 1
c inc -20 if c == 10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}