import re
regex = re.compile(r"([a-z]+) (inc|dec) (-?\d+) if ([a-z]+) (.+) (-?\d+)")
test_str = ("b inc 5 if a > 1\n"
"a inc 1 if b < 5\n"
"c dec -10 if a >= 1\n"
"c inc -20 if c == 10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")