import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n";
final String string = "2\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "1\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "B 118c\n\n"
+ "(Herr Harbrecht)\n\n"
+ "LF9 TBM\n\n"
+ "1\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "FPM 71 TBM\n\n"
+ "Raumänderung\n\n"
+ "+B 101 (B 113)\n\n"
+ "Frau Gottschalk\n\n"
+ "BW\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "Raumänderung\n\n"
+ "+B 101 (B 113)\n\n"
+ "Frau Gottschalk\n\n"
+ "BW\n\n"
+ "3\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "FS TET 81\n\n"
+ "Fällt aus\n\n"
+ "M H1-2.37\n\n"
+ "(Herr Kahnke)\n\n"
+ "LF13\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-2.37\n\n"
+ "(Herr Kahnke)\n\n"
+ "LF13\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "IME 61\n\n"
+ "Auf 18.06. Di 6 verschoben\n\n"
+ "M H1-3.32\n\n"
+ "Herr Schmidt\n\n"
+ "ILF 9\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Auf 18.06. Di 5 verschoben\n\n"
+ "M H1-3.32\n\n"
+ "Herr Schmidt\n\n"
+ "ILF 9\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n\n"
+ "Von 18.06. Di 8 verschoben\n\n"
+ "+M H1-3.32 (M H1-3.10)\n\n"
+ "+Herr Schmidt (Herr Patett)\n\n"
+ "+ILF 9 (ILF 6)\n\n"
+ "6\n\n"
+ "6\n\n"
+ "18.06.2019\n\n\n"
+ "Von 18.06. Di 7 verschoben\n\n"
+ "+M H1-3.32 (M H1-3.10)\n\n"
+ "+Herr Schmidt (Herr Patett)\n\n"
+ "+ILF 9 (ILF 6)\n\n"
+ "5\n\n"
+ "5\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "ITK 71\n\n"
+ "Zusatzunterricht\n\n"
+ "M H1-1.31\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "M H1-1.31\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "3\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "KFM 82\n"
+ "Fällt ausM H1-1.17(Herr Geilus)LF88818.06.2019\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.17\n\n"
+ "(Herr Geilus)\n\n"
+ "LF8\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.17\n\n"
+ "(Herr Geilus)\n\n"
+ "LF8\n\n"
+ "6\n\n"
+ "6\n\n"
+ "18.06.2019\n\n\n"
+ "M H1-1.17\n\n"
+ "+Herr Lesch (Herr Geilus)\n\n"
+ "LF5\n\n"
+ "5\n\n"
+ "5\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "KOM 71\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.17\n\n"
+ "(Herr Geilus)\n\n"
+ "LF8\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.30\n\n"
+ "(Herr Brauckhoff)\n\n"
+ "LF2\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.30\n\n"
+ "(Herr Brauckhoff)\n\n"
+ "LF2\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n\n"
+ "Von 19.06. Mi 7 verschoben\n\n"
+ "+M H1-1.31 (M H1-1.17)\n\n"
+ "+Herr Rohde (Herr Geilus)\n\n"
+ "+D (LF4)\n\n"
+ "4\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "M H1-1.31\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "Von 19.06. Mi 8 verschoben\n\n"
+ "+M H1-1.31 (M H1-1.17)\n\n"
+ "+Herr Rohde (Herr Geilus)\n\n"
+ "+D (LF4)\n\n"
+ "3\n\n"
+ "3\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "M H1-1.31\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "3\n\n"
+ "18.06.2019\n\n\n"
+ "Raumänderung\n\n"
+ "M H1-1.17\n\n"
+ "+Herr Dick (Herr Geilus)\n\n"
+ "LF3\n\n"
+ "2\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.17\n\n"
+ "(Herr Geilus)\n\n"
+ "LF3\n\n"
+ "1\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "KOM 82\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "MAL 71\n\n"
+ "+B 231 (B 310)\n\n"
+ "+Herr Christochowitz (Frau Schulz)\n\n"
+ "LF5\n\n"
+ "4\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "+B 231 (B 310)\n\n"
+ "+Herr Christochowitz (Frau Schulz)\n\n"
+ "LF5\n\n"
+ "3\n\n"
+ "3\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "B 105\n\n"
+ "(Frau Nevermann)\n\n"
+ "D\n\n"
+ "2\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "B 105\n\n"
+ "(Frau Nevermann)\n\n"
+ "D\n\n"
+ "1\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "MAL 72\n\n"
+ "Fällt aus\n\n"
+ "B 129\n\n"
+ "(Herr Lehmann)\n\n"
+ "En\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "B 129\n\n"
+ "(Herr Lehmann)\n\n"
+ "En\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n"
+ "statt 7./8.\n\n\n"
+ "B 118c\n\n"
+ "+Herr Lehmann (Herr Harbrecht)\n\n"
+ "+En (LF9)\n\n"
+ "6\n\n"
+ "6\n\n"
+ "18.06.2019\n\n"
+ "statt 7./8.\n\n\n"
+ "B 118c\n\n"
+ "+Herr Lehmann (Herr Harbrecht)\n\n"
+ "+En (LF9)\n\n"
+ "5\n\n"
+ "5\n\n"
+ "18.06.2019\n\n\n"
+ "+B 301 (B 304)\n\n"
+ "+Herr Freiheit (Herr Just)\n\n"
+ "LF8\n\n"
+ "2\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "+B 301 (B 304)\n\n"
+ "+Herr Freiheit (Herr Just)\n\n"
+ "LF8\n\n"
+ "1\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "MAU 71\n"
+ "MAU 71 und MAU 72 gemeinsam\n\n\n"
+ "+B 304 (B 118c)\n\n"
+ "+Herr Just (Herr Harbrecht)\n\n"
+ "LF9\n\n"
+ "4\n\n"
+ "4\n\n"
+ "18.06.2019\n\n"
+ "MAU 71 und MAU 72 gemeinsam\n\n\n"
+ "+B 304 (B 118c)\n\n"
+ "+Herr Just (Herr Harbrecht)\n\n"
+ "LF9\n\n"
+ "3\n\n"
+ "3\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "MAU 72\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.13\n\n"
+ "(Herr Kahnke)\n\n"
+ "LF4\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "Fällt aus\n\n"
+ "M H1-1.13\n\n"
+ "(Herr Kahnke)\n\n"
+ "LF4\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n\n"
+ "Raumänderung\n\n"
+ "+M H1-1.42 (M H1-1.43, M H1-1.13)\n\n"
+ "Frau Wegener\n\n"
+ "D\n\n"
+ "6\n\n"
+ "18.06.2019\n\n\n"
+ "Raum fehlt\n\n"
+ "(M H1-1.43), M H1-1.13\n\n"
+ "Herr Kahnke\n\n"
+ "LF3\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "Raum fehlt\n\n"
+ "(M H1-1.43), M H1-1.13\n\n"
+ "Herr Kahnke\n\n"
+ "LF3\n\n"
+ "3\n\n"
+ "18.06.2019\n\n\n"
+ "Raum fehlt\n\n"
+ "(M H1-1.43), M H1-1.13\n\n"
+ "Herr Ruynat\n\n"
+ "LF2 z\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Raum fehlt\n\n"
+ "(M H1-1.43), M H1-1.13\n\n"
+ "Herr Ruynat\n\n"
+ "LF2 z\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "SME 83\n\n"
+ "M H1-2.28\n\n"
+ "+Herr Eisak (Herr Barz)\n\n"
+ "ET\n\n"
+ "6\n\n"
+ "6\n\n"
+ "18.06.2019\n\n\n"
+ "M H1-2.28\n\n"
+ "+Herr Eisak (Herr Barz)\n\n"
+ "ET\n\n"
+ "5\n\n"
+ "5\n\n"
+ "18.06.2019\n\n\n"
+ "+Herr Lübcke (Herr Barz)\n\n"
+ "ET\n\n"
+ "4\n\n"
+ "4\n\n"
+ "18.06.2019\n\n\n"
+ "+Herr Lübcke (Herr Barz)\n\n"
+ "ET\n\n"
+ "3\n\n"
+ "3\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "WER 61\n\n"
+ "+B 118c (B 310)\n\n"
+ "+Herr Peters (Frau Schulz)\n\n"
+ "FT\n\n"
+ "8\n\n"
+ "8\n\n"
+ "18.06.2019\n\n\n"
+ "+B 118c (B 310)\n\n"
+ "+Herr Peters (Frau Schulz)\n\n"
+ "FT\n\n"
+ "7\n\n"
+ "7\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "WER 71 2HJ\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "2\n\n"
+ "18.06.2019\n\n\n"
+ "Zusatzunterricht\n\n"
+ "B 109\n\n"
+ "Frau Istrati\n\n"
+ "DaZ\n\n"
+ "1\n\n"
+ "18.06.2019\n\n"
+ "Info\n\n"
+ "Art\n\n"
+ "Raum\n\n"
+ "Lehrer Name\n\n"
+ "Fach\n\n"
+ "Pos\n\n"
+ "Datum\n\n"
+ "Di 18.06.2019\n"
+ "ZIM 72";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}