# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-0$|^-?0\d+(?:\.\d+)?$|^(-?\d+(?:.\d{1,4})?)$"
test_str = ("0\n"
"0.1\n"
"0.12\n"
"0.123\n"
"0.1234\n"
"1\n"
"1.1\n"
"123456789.1234\n"
"-0.1\n"
"-0.12\n"
"-0.123\n"
"-0.1234\n"
"-1\n"
"-1.1\n"
"-123456789.1234\n\n"
"-\n"
"+\n"
"-0\n"
"0123456789.1234\n"
"007\n"
"+0.1\n"
"+123456789.1234\n"
".1234\n"
"1.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.