using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?),\s*(?:(.+?),)?\s*(.+?)$";
string input = @"city, state, country
city, country
Baltimore, MD, USA
Baltimore, Maryland, United States
Milan, Italy
Paris, France
Calgary, Alberta, Canada
Example Bad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}