package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^()]*|\([^()]*\))*\))|(\w+)`)
var str = `if ((a and b) or (a and)) or (c and d) or (e and f)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}