const regex = /[\u30a0-\u30ff\u3040-\u309f]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u30a0-\\u30ff\\u3040-\\u309f]', 'gm')
const str = `dアdd達[になれた] 桃五[いつ]つ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}