use strict;
my $str = 'm/d/yyyy 1,21,3,42,5,63,7,84,9';
my $regex = qr/(?<!\d)[1-9](?!\d)/mp;
my $subst = '0$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";