import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<firstName>\\p{Lu}(?:\\.|\\p{Ll}+)(?: \\p{Lu}\\.)?) (?<lastName>\\p{L}\\p{Ll}+(?:\\p{Pd}\\p{Lu})?\\p{Ll}+)$";
final String string = "John Smith\n"
+ "John S. Smith\n"
+ "J. R. Smith";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}