import Foundation
let pattern = #"^(?<firstName>\p{Lu}(?:\.|\p{Ll}+)(?: \p{Lu}\.)?) (?<lastName>\p{L}\p{Ll}+(?:\p{Pd}\p{Lu})?\p{Ll}+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
John Smith
John S. Smith
J. R. Smith
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)