re = /^(?:(.*?):)?\s*(.*)$/m
str = 'message accepted
update: message received
new status: user online
no new messages'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end