#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([E]\d{5}-\d{2})"
Local $sString = "Like E12345-01 does not be"
Local $sSubst = "<a href="http://somepage.com?number=$1">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)