// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([E]\d{5}-\d{2})").unwrap();
let string = "Like E12345-01 does not be";
let substitution = "<a href=\"http://somepage.com?number=$1\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}