using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[!@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z]).{8,15}$";
string input = @"[]{}sS3_sss";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}